[Resolved] Exchange rates API experiencing intermittent failures
Incident Report for Open Exchange Rates
Resolved
This platform issue caused request timeouts for many of our API clients, between approximately 00:30 UTC and 13:00 UTC on January 1st.

This resulted from an unprecedented number of API requests on New Year's Day, occurring in a way that did not allow our platform to efficiently auto-scale, due to an unexpected bottleneck between our database and cache.

We began investigation as soon as we became aware of this issue, and resolved it with a deployment later in the day.

Although a small number of clients continued to experience occasional timeouts for up to 48 hours afterwards, we have not experienced a recurrence of this issue. We have since made further infrastructure updates to safeguard your service.

We sincerely apologise for any inconvenience this may have caused you. Please rest assured that we continue to closely monitor our API platform and responses for unexpected behaviour, providing you with the consistent and stable service availability you expect.

Please don't hesitate to contact us if you have any questions or concerns about this incident.

Warm regards,
Open Exchange Rates Team
Posted 14 days ago. Jan 09, 2017 - 15:40 UTC
Monitoring
This incident caused connection timeouts for a large number of API clients. We have now deployed a fix and will continue to monitor throughout the day, with a post-mortem to follow shortly.
Posted 22 days ago. Jan 01, 2017 - 17:29 UTC
Update
We are continuing to investigate this issue and will provide an update as soon as we have further information.
Posted 23 days ago. Jan 01, 2017 - 10:18 UTC
Investigating
A number of clients have reported receiving timeouts while connecting to our API over the past few hours. We are investigating and will respond as soon as we have further information.
Posted 23 days ago. Jan 01, 2017 - 07:05 UTC