Usage statistics delayed
Incident Report for Open Exchange Rates
Resolved
Usage statistics are being displayed with up to 12 hours delay, otherwise functional. Please get in touch with any questions.
Posted Dec 09, 2015 - 17:43 UTC
Monitoring
Usage statistics were temporarily delayed due to a non-critical database error. A fix has been deployed and usage stats will be recalculated for all clients over the next 2 days.

At present and until further notice, API usage volume will take 24-48 hours to be reflected in your account dashboard. We apologise for any inconvenience caused.
Posted Nov 30, 2015 - 14:15 UTC