SGD (Singapore Dollar) rate incident, Sunday 8th May
Incident Report for Open Exchange Rates
Resolved
This incident was resolved at 19:05 UTC on 2022-05-08.
Posted May 10, 2022 - 19:15 UTC
Investigating
We experienced an unexpected spike in SGD (Singapore Dollar) rates in the Open Exchange Rates API on Sunday 8th May, between approx. 07:15 UTC and 19:05 UTC. A fix has been implemented and we are continuing to investigate the root cause with our data contributors. Please contact support@openexchangerates.org if you experience any further issues.
Posted May 08, 2022 - 07:15 UTC
This incident affected: Exchange Rate API.