API connection failures and missing currencies in latest/historical rates
Incident Report for Open Exchange Rates
Resolved
This incident has been resolved. We are continuing to make ongoing improvements to our platform to prevent any recurrence.
Posted Mar 21, 2023 - 13:00 UTC
Update
The repeat occurrence this morning began at 07:35 UTC, after which a small number of currencies appeared as unavailable in our service, and it was resolved again by 07:55 UTC. The API has been operational since this time. However, clients are advised that our incident response is still in progress, and we are continuing to work on full remediation. Although we are working hard to avoid any further disruption in service, it is possible that the API may experience further performance issues over the next 48 hours, while we implement our solution. Please stand by for further updates.
Posted Mar 14, 2023 - 12:42 UTC
Identified
Please be advised that we experienced further issues relating to yesterday's incident this morning, beginning at 07:35 and causing degraded performance on our API. We are working on a solution and will continue to update this post with any additional information.
Posted Mar 14, 2023 - 08:00 UTC
Monitoring
Missing currency symbols have now been restored to the live API results and we are continuing to monitor the service performance and investigating the root cause.

Note: Although latest.json and historical/.json endpoints are restored, affected symbols may be unavailable for certain historical ohlc.json and spot.json requests coinciding with the incident period.

Please contact us at support@openexchangerates.org if you need any further support.
Posted Mar 13, 2023 - 17:10 UTC
Update
We are continuing to work to restore the missing values to the API after this morning's service interruption.

The following symbols remain temporarily unavailable in our latest API results:

> SRD, TMT, XCD

Our earlier scheduled maintenance was successfully completed after approximately 12 minutes, with no reported API downtime during this period.
Posted Mar 13, 2023 - 14:45 UTC
Update
We are continuing to work to restore the missing values to the API after this morning's service interruption.

The following symbols are currently still affected by this incident and remain temporarily unavailable in our latest API results:

> AOA, AWG, GEL, GMD, IRR, KMF, LRD, MVR, MZN, NAD, SBD, SDG, SRD, TMT, TND, VES, XCD, YER

In addition, we will be undergoing scheduled maintenance at 12:55 UTC.

We aim to keep this maintenance window as short as possible, however the API may be unavailable for up to 30 minutes while this is underway.
Posted Mar 13, 2023 - 12:42 UTC
Update
We will shortly undergo a maintenance window during which our API and some areas of our website will be temporarily unavailable.

Please refer to the separate Scheduled Maintenance update (to be posted shortly) for more details including the maintenance window time.

We aim to keep this maintenance period to a minimum, however please be advised that the service may be unavailable for up to 30 minutes after the beginning of the scheduled maintenance.
Posted Mar 13, 2023 - 11:25 UTC
Identified
We have identified the issue, and are continuing to work on a solution.
Posted Mar 13, 2023 - 07:43 UTC
Update
We are continuing to investigate this issue.
Posted Mar 13, 2023 - 04:36 UTC
Update
We are continuing to investigate this issue.
Posted Mar 13, 2023 - 04:28 UTC
Update
Please be advised Open Exchange Rates API is currently running with partial outage.

Latest and historical rates for today's date, and other API queries, may be unavailable.

We are continuing to investigate this issue.
Posted Mar 13, 2023 - 03:06 UTC
Investigating
We are currently investigating connection failures on our API. Please stand by for updates.
Posted Mar 13, 2023 - 03:00 UTC
This incident affected: Exchange Rate API.