We're upgrading our website
Incident Report for Open Exchange Rates
Resolved
This incident has been resolved.
Posted Jan 02, 2016 - 11:08 UTC
Identified
We're currently upgrading our front-end website and client account dashboard, in several stages. Visitors may see old pages alongside the new ones while we make the switch-over.

This is a design and content issue only. The API is fully operational.

Please contact us if you notice anything out of place or missing.
Posted Dec 15, 2015 - 08:01 UTC